Microsoft Office Еxcel

Уикипедия — ашық энциклопедиясынан алынған мәлімет
Мұнда ауысу: шарлау, іздеу
Microsoft Excel (Windows)
Excel логотип
Microsoft Excel 2010
Microsoft Excel 2010
Кім дамытқан Microsoft
Соңғы шығармасы 14.0.6023.1000 / 27 маусым 2011
Амалдық жүйесі Microsoft Windows
Жанры Кесте құрастырушы
Лицензиясы Microsoft EULA
Ғаламтор торабы Бағдарламаның бас беті

Microsoft Еxcel -1979 жылы екі экономист студент Дэн Бриклин және Боб Френкстон үй тапсырмасын тез орындауға көмектесетін және уақытты үнемдейтін әдіс ойлап табуды шешті. олар тарихта бірінші рет электронды кесте бағдарламасын жазып, оны Visible Calculator сөзінен қысқартылған VisiCalc (Көрсеткіш калькулятор) деп атады. сондықтан барлық электрондық кестелер бағдарламасы, оның ішінде Excel программасы Дэн мен Бобтың арқасында жүзеге асты. IBM және Macintosh компьютерлерінде жұмыс істейтін, ең озық үлгілерді ала отырып, бүгінгі заман талабына сай жасалған, электрондық кесте құрастыратын қолданбалы программа. Excel-дің соңғы нұсқаларында график тұрғызу, күрделі функциялар арқылы есеп-қисап жүргізу және бірнеше жұмыс кітаптарымен қатар жұмыс атқару сияқты мүмкіндіктер кеңінен қолданылады. Кестелік құрылымды құжаттармен жұмыс істеуге арналған кең таралған құралдардың бірі Microsoft Excel. Ол сандық мәліметтермен жұмыс істеу үшін негізделген.

Excelдің маңызы[өңдеу]

Excel жай ғана бағдарлама емес, оны көптеген математикалық амалдарды, күрделі есептерді жеңілдету үшін пайдалануға болады. Ол кестедегі мәліметтердің негізінде түрлі-түсті диаграмммалар тұрғызып, жүргізуді қамтамасыз ете алады. Excel мүмкіндігінің көпжақтылығы тек экономика саласында ғана емес, ғылыми зерттеу, әкімшілік жұмыстарында да кеңінен қолданылады.

Нұсқалары[өңдеу]

  • 1988 — Excel 2.0
  • 1990 — Excel 3.0
  • 1992 — Excel 4.0
  • 1993 — Excel 5.0 (Windows NT)
  • 1995 — Excel 7 (Windows 95)
  • 1997 — Excel 97
  • 1999 — Excel 2000 (9) — Microsoft Office 2000
  • 2001 — Excel 2002 (10) — Microsoft Office XP
  • 2003 — Excel 2003 (11) — Microsoft Office 2003
  • 2007 — Excel 2007 (12) — Microsoft Office 2007
  • 2010- Excel 2010 (13)-Microsoft Office 2010
  • 2012- Excel 2013 (14)-Microsoft Office 2013

Жұмыс кітабы[өңдеу]

Excel даярлайтын құжат Жұмыс кітабы деп аталады. Жұмыс кітабы жұмыс парағынан тұрады. Жұмыс парағының құрылымы кестенің құрылымындай және ол бір немесе бірнеше кестені қамтиды. Әрбір парақтың аты төменгі жағында орналасқан таңбашада көрініп тұрады. Осы таңбашаның көмегімен кітапты парақтауға болады. Таңбашаны тышқанның батырмасын екі рет басу арқылы өзгертуге болады. Әрбір жұмыс парағы жолар мен бағандардан тұрады. Бағандардың аты латын алфавитінің бас әріптерімен жазылады. Бір жұмыс парағы 256-ға дейін баған санын қамти алады. Бағандар А-дан ZZ әріптерінің комбинацияларымен белгіленеді, ал жолдар 1-ден бастап 65536-ға дейін нөмірленеді. Бағандар мен жолдардың қиылысуы ұяшықтар деп аталады. Ол электрондық кестенің мәлімет енгізетін ең кіші элементі болып табылады. Әрбір ұяшықтың жол мен бағандардың белгіленуінен тұратын адресі болады. Мысалы: А9, D21, F5, G7, L16. Әрқашанда ұяшықтардың біреуі ағымдық ұяшық болып есептеледі және жақтаумен ерекшеленіп тұрады. Осы жақтау кестелік меңзердің рөлін атқарады және тышқанның немесе басқару пернелердің көмегімен экранда жылжыта аламыз. Мәліметтерді енгізу, пішіндеу және басқада іс-әрекеттер осы ағымдағы осы ұяшықта жүзеге асырылады. Бірнеше ұяшықтар тобын ұяшықтар ауқымы деп атаймыз. Ауқымдар тік төртбұрыш қалыпты болады. Оларды былай белгілейді: A7: E25. Мұндағы А7 – тік төртбұрыштың сол жақ жоғарағы, ал Е25 – оң жақ төменгі бұрыштары. Мәліметтер типі. Кестенің ұяшықтарына мәліметтердің келесі үш типінің біреуін ғана енгізе аламыз. Ол мынадай типтер:

  • Сан
  • Формула
  • Мәтін

Мәліметтерді өңдеу[өңдеу]

Енгізілетін мәліметтің сан немесе формула екенін оның алғашқы символына қарап анықтайды. Егер енгізілетін символдың біріншісі сан болса, онда оны сандық типке жатқызамыз. Егер біріншісі теңдік белгісі болса, формула деп қабылдайды. Егер бірінші символымыз әріп немесе апостроф болса, мәтін деп қабылдайды. Мәліметтерді енгізу Enter пернесін басумен жүзеге асырылады. Енгізілген мәліметтерді енгізбей алып тастау үшін немесе ұяшықтың бастапқы мәндерін қалпына келтіру үшін esc пернсін басамыз немесе формулалар жолындағы Болдырмау (отмена) батырмасын шертеміз. Excel-де енгізілген сандық мәліметтер автоматты түрде ұяшықтардың оң жақшетіне орналасады. Сандық пішімде. Экономикалық есептерде санның үш түрлі пішімде жазылуы қолдананылады: кәдімгі сандық пішім, қаржылық және мерзімдік. Кәдімгі сандық пішім әр түрлі сандқ шамаларды жазуға арналған. Мысалы: қайсыбір тауардың санын, пайзын жас мөлшерін және т.б. Ақша сомасын енгізу қаржылық пішімде жүзеге асырылады. Уақыт мезгілін жазу үшін мерзімдік пішім пайдалынылады. Мәтіндік пішім. Мәтіндік пішім мәтіндік жолдар мен цифрмен көрсетілген сандық емес мәліметтерді жазу үшін қолданады. Бұларға жататындар: регистрациялық нөмірлер, поштаның индексі, телефонның нөмірі. Ағымдағы ұяшықтың немесе ерекшеленген ауқымдығы мәлдіметтердің пішімін өзгерту үшін Пішім > Ұяшықтар(Формат > Ячейки) командасын пайдаланады. Ашылған Ұяшықтарды пішімдеу (Формат ячеек) сұхбат терезесіндегі қыстырмалардан мәліметтердің жазылу пішімін таңдап алады. Сол терезеде мәтіннің бағытын көрсетіп, оны түзеу, қарпін өзгерту, символдардың жазлуын, фонның түсін, жақтаудың түрін анықтайтын параметірлерді енгізуге болады. Excel програмысының кестесіндегі есептеулер формулалардың көмегімен жүзеге асырылады. Формулалар тұрақты сандардан, ұяшықтарға сілтеме мен Excel функцияларынан тұрады. Егер ұяшықтарға формулалар енгізілген болса, онда жұмыс парағында осы формуланың есептеу нәтижесі белгіленіп тұрады. Ұяшықтағы сандық нәтижені емес, оған енгізілген формуланы көру үшін сол ұяшықты ерекшеп алып, формулалар жолында бейнеленген жазуға көзсалу керек. Ұяшықтарда адрес көрсетіледі оны ұяшықтарға сілтеме деп атаймыз. Есептеу нәтижесі формуладағы пайдалынылған ұяшықтарға тәуелді болады. Тәуелді ұяшықтағы мәндер бастапқы ұяшықтағы мәндердің өзгеруіне байланысты өзгеріп тұрады. Ұяшықтарға сілтемені әр түрлі тәсілдермен беруге болады: • біріншіден, ұяшықтың адресін қолмен теруге болады; • екінші тәсілі қажетті ұяшыққа тышқанмен шерту арқылы ерекшелеп енгізуге болады. Салыстырмалы сілтеме. Формулаларды бір ұяшықтан екіншісіне көшіргенде нәтиже қандай болатыны сілтеменің адрестеуіне тікелей тәуелді. Кәдімгі жағдайда формуладағы ұяшықтарға сілтеме салыстырмалы болып табылады. Бұл формулаларды бір ұяшықтан екінші ұяшыққа көшіргенде сілтеменің адресі автоматты түрде өзгереді деген сөз. Мысалы: В2 ұяшығында одан бір жол солға қарай және төмен орналасқан А3 ұяшығына сілтеме орналассын. Егер осы формула көшірлсе, онда сілтеменің салыстырмалы көрсеткіші сақталады. Мысалы: А9, D25, F5 салыстырмалы сілтеме болып табылады.

Абсолют сілтеме[өңдеу]

Абсаолют адрестеу кезінде формула көшірілгенде сілтеменің адресі өзгермейді, сілтеме көрсетіп тұрған ұяшық тұрақтыы болып қалады. Формулаларды редактерлеу кезінде адрестеу әдісін өзгерту үшін ұяшықтың сілтемесін ерекшелеп алып F4 басу керек. Абсалют адрестелінген ұяшықтың нөмірінің алдына $ белгісін қояды. Мысалы: $А$16, $А9, А$7. Соңғы екі жағдайда ұяшық нөмірлерінің бірі абсолют, екіншісі салыстырмалы болып есептеледі, бұл аралас сілтеменің мысалдары. Әдетте кестелер қайталатын, біртектес мәліметтен тұратындықтан, Excel программасының енгізуді автоматтандыратын құралдары бар. Оларға жататындар автотолтыру, формулалармен автотолтыру.

Автотолтыру[өңдеу]

Мәтіндік мәліметтерді автоматтандыру үшін авто толтыру әдісін қолданады. Оны жұмыс парағының бір бағанына бірнеше рет қайталанатын мәтіндік жолды енгізгенде пайдаланады. Мәтінді енгізу кезінде программа оны жоғарғы жолдармен салыстырып, бірдей элементтер кездессе автоматты түрде толтырады.

Сандарды автотолтыру[өңдеу]

Сандармен жұмыс істеген кезде автолтыру әдісі пайдаланады. Ағымдығы ұяшықтың қоршауының төменгі бұрышында кішкентай қара түсті шаршы орналасқан. Оны толтыру маркері деп атайды. Тышқанның нұсқағышын сол маркерге алып барса, оның пішіні кішкентай крест тәрізді болып өзгереді. Сол кезде маркерді тік немесе көлденең тасымалдау арқылы автолтыру жүзеге асырылады.

Прогресия бойынша толтыру[өңдеу]

Ол үшін Түзету > Толтыру > Прогрессия (Правка > Заполнить > Прогрессия) орындау керек. Ашылған прогрессия сұхбат терезесінде прогрессияның тегі, қадам мөлшері, шектік мәні таңдап алынады. ОК батырмасын басқаннан кейін Excel программасы берілген ережелер бойынша ұяшықтарды автоматты түрде толтырып береді. Формулаларды автолтыру. Бұл амал сандарды автотолтыру сияқты жүзеге асырылады. Автоттолтыру кезінде формулалардың басқа ұяшықтарға сілтеменің ерекшеліктері ескеріледі: салыстырмалы сілтемелер сәйкесінше көшірменің салыстырмалы орналасуына байланысты өзгереді. Ал абсолют сілтемелер өзгермей сол қалпында қалады. Мысалы: үшінші С Бағанында мәні А және В бағандарының сәйкес ұяшықтардағы мәндерінің қосындысына тең формула есептелсін. С1 ұяшығында =A1+B1 формуласын енгіземіз, осы формаланы автотолтыру әдісімен үшінші бағанның барллық ұяшықтарына көшіреміз. Автотолтыру кезіндегі сілтемелердің жаңару ережелері келесі кестеде көрсетілген:

Бастапқы ұяшықтардағы сілтеме Келесі ұяшықтағы сілтеме Оңға толтыру кезінде Төмен толтыру кезінде А1 (салыстырмалы) В1 А2 $А1 (бағана бойынша абсоллют) $А1 $А2 А$1 (жол бойынша абсолют) В$1 А$1 $А$1 (абсолют) $А$1 $А$1

Excel программасында стандарт функциялар тек формулаларда ғана қолданылады. Функцияны шақыру ішін формулада функцияның атын көрсету қажет. Функция егізілгеннен кейін жақшада оның параметрлері көрсетіледі. Параметр ретінде сан, ұяшықтар немесе басқа да бір өрнектер алынады. Формулалар. Егер формулаларды Функцияларды өзгерту (Изменить функций) батырмасын басу арқылы немесе Кірістіру > Функция командасын жүзеге асыратын болса, онда формулалар жолының астында Функцялар шебері (Мастер функций) аты сұхбат терезе ашылады. Ал оның анелінде функциялар тізімі ашылады. Оның Категория бөлімінде ең соңғы пайдалынылған он функция және төменірек басқа функциялар бөлімі бейнеленеді. Функция шеберін қолдану. Функция шеберінің Категория тізімінен қажетті функцияны категориясы бойынша таңдап алуға болады. Функциялар тізімінен берілген категория бойынша нақты функция алынады. ОК пернесін шерткеннен кейін, қажеттіфункцияның аты формулалар жолына енгізіледі. Ал мәтіндік меңзер сол функцияның параметрлері көрсетілген жақшалардың арасына орналасады. Функцияның парамерлерін енгізу. Функияның параметрлерін енгізі кезінде формулалар терезесінің түрі өзгереді. Мұнда параметрлерді енгізуге арналған өріс бейнеленеді. Егер параметрдің аты жартылай майлы қаріппен көрсетілсе, онда бұл параметрді мүндетті түрде енгізу қажет. Ал егер параметрдің аты жәй қаріппен көрсетілетін болса, ол параметрді тастап кетуге болады. Формулалар терезесінің төменгі жағында функцияның қысқаша көшірмесі сиппатамасы мен параметірлерінің өзгеру аралықтары беріледі. Қорытынды есептеулер. Шебердің көмегімен алынатын көптеген функциялардың көп бөлігі ғылыми есптеулерге арналған. Қаржымен байланысты есептерді орындауға арналған қаржы функциясы өз алдына бір категорияны құрайды. Экономикалық және бухгалтерлік есептеулерде негізінен қорытындылау функциялары қолданылады. Бұл функцияларға ортақ қасиет, олардың параметрлерінің тізіміне енетін параметрлер саны алдын-ала белгісіз болуы мүмкін, өйткені олар әр жағдайда әр қалай, ал нәтижесінде барлық параметрлерді сипаттайтын ортақбір сан алынады. Осы типтес нақты функциялар әр түрлі категорияларда орналасқан, соның ішінде көп бөлігі Математикалық және Статистикалық категорияларында орналасқан.

Қосындылау функциясы[өңдеу]

Қортындылау функцияларының ішіндегі ең көп қолданылатыны қосындылау функциясы – СУММ. Стандартты аспаптар панелінде осы функцияда ғана жеке батырма бар – Автоқосынды (Автосумма) батырмасы. Автоматты түрде қосындылау ағымдағы ұяшықтың немесе сол жағындағы ауқымды қамтиды. Автоматты түрде таңдалынып алынған ауқымды қайтадан өзгертіп, функцияның қосымша параметрлерін беруге болады. Қортындылау есептеулеріне арналған басқа функциялар Функцияларды өзгерту батырмасы немесе Функциялар шеңбері арқылы алынады. Бұл функциялардың қатарына ДИСП (дисперсия), МАКС (ауқымдағы ең үлкен сан), МИН (ауқымдағы ең кіші сан), СРЗНАЧ (ауқымдағы сандардың арифметикалық ортасы), СЧЕТ (ауқымдағы мәндері бар ұяшықтар саны) және т.б. жатады. Көптеген экономикалық есептерді жеңілдету үшін функциялар қолданылады. Функциялар y = f(x) түрінде жазылады, мұндағы х – функцияның аргументі, ал у – функцияның мәні, f – функция. Функцияларды қолдануға мысалы қарастырайық: С7 ұяшығында АВС(А7) + LOG(В7( формуласын есептейік). Мұндағы А7, В7 – ұяшықтарға салыстырмалы сілтемелер; АВС(А7) – А7 ұяшығындағы мәннің абсалютті шамасын есептейтін функция; LOG(В7) – В7ұяшығындағы мәннің логарифімін есептейтін функция. Excel програмысында қолданылатын стандарт функциялар тізімі: • SIN, COS, TAN – тригонометриялық функциялар; • ASIN, ACOS, ATAN – кері тригонометриялық функциялар; • МАКС, МИН, СРЗНАЧ – массивтерге қолданылатын функция; • LN, LOG, LOG10 – натурал, жай ондық логарифмдер; • КОРЕНЬ – кватрад он түбірді анықтайтын функция; • ЕСЛИ, И, НЕ, ИЛИ, ЛОЖЬ – логикалық функциялар; • ЗАМЕНИТЬ, НАЙТИ, КОДСИМВ, ЛЕВСИМВ, ПОВТОР- мәтіндік функциялар. Бұл тізімді әрі қарай жалғастыра беруге болады, өйткені олардың саны өте көп. Ұяшықтағы мәліметтерді қорғау. Excel програмасында бүкіл жұмысы кітабын кез-келген парақты немесе ұяшықты қайсыбір көлденең жағдайлардан, сақтап қоюға болады. Мәліметтерді қорғап қою оны өзгерістерден қорғау қасиетін алып тастағанға дейін сақталады. Әдетте жиі өзгермейтін мәліметтер ( есептеу формалары, кестенің тақырыптары, ұяшықтың аттары) ғана өзгертуден қорғалуы тиіс Мәліметтерді қорғау екі бөліктен тұрады: • өзгертілуге тиіс ұяшықтардың бұрынғы қорғау қасиеттері алынады; • ағымдағы парақа немесе оның кейбір ауқымдарына қорғалу қасиеті енгізіледі. Бұдан кейін тек қорғалу енгізілген ұяшықтар мен ауқымдарға ғана мәліметтер енгіземіз. Ұяшықтардың қорғалу қасиетін енгізу. Қажетті ауқымды ерекшелеп алып, содан кейін Пішім > Ұяшықтар > Қорғау (Формат > Ячеики > Защита) командасын орындап, ашылған Ұяшықтарды пішімдеу (Формат ячеек) сұхбат терезесінің Қорғау (Защита) қсытырмасындағы жалаушыларды орнатамыз немесе алып тастаймыз.

Excel- де диаграммаларды тұрғызу[өңдеу]

Excel программасындағы диаграмма термині сандық мәліметердің графиктік түрде бейнеленуінің барлық жағын қамтиды. Графиктік бейнелеу берілген мәліметтер қатары негізінде құрылады. Берілген мәліметтері бар жеке алынған жол немесе бағаннан тұратын ұяшықтар тобы мәліметер тобын құрайды. Бір диаграммада бірнеше мәліметтер қатарын бейнелеуге болады. Диаграмма деп жұмыс кітабының бір парағына енгізілген графиктік обьектіні айтады. Ол мәліметтер тұрған парқта немесе кез-келген басқа парақта орналасуы мүмкін. Диаграмма өзі тұрғызылған мәліметтермен әрқашан тығыз байланыста болады. Егер мәліметтер жаңартылатын болса, диаграмма да автоматты түрде соған сәйкес өзгереді. Диаграмманы тұрғызу үшін Диаграмма шебері (Мастер диаграмм) қолданылады. Ол стандарты аспаптар панелінде орналасқан диаграмма шебері батырмасының көмегімен іске қосылады. Әдетте диаграмма тұрғызар алдында мәліметтер орналасқан аймақты ерекшелеп алады немесе бұл мәліметерді Диаграмма шеберінің барысында енізуге болады. Диаграмманың түрін таңдап алу. Диаграмма шеберінің алғашқы сатысында диаграмманың түрін таңдап алуымыз қажет. Стандартты қыстырмасындағы Түр (Вид) тізімінде диаграмманың қолда бар түрлері көрсетілген. Таңдап алынған түр үшін терезенің оң жағында мәліметтердің көрсетілуінің түрлі нұсқаулары көрсетілген. Сонын ішінен ең қолайысын таңдауымыз қажет. Стандарты емес қыстырмасында пішімделген, толығымен қалыптасқан диаграмма түрлері бейнеленген. Диаграмманың түрін таңдап алынғанна кейін Ары қарай ( Далее ) батырмасын басамыз.

Мәліметтерді таңдап алу[өңдеу]

Диаграмма шебері (Мастер диаграмм) жұмысының екінші сатысы диаграмма тұрғызылатын мәліметтердің таңдап алудан басталады. Егер мәліметтер ауқымы алдын- ала берілген болса, Диаграмма шебері терезесінің үстінгі жоғарғы бөлігінде орналасқан адын-ала қарап шығу аймағында тұрғызылатын диаграмманың жуық бейнесі пайда болады. Егер мәліметтер бірдей ауқымды тік төртбұрышты қамтитын болса, онда оны мәліметтер ауқымы (Диапазон данных) қыстырмасы бойынша таңдап алған қолайлы. Егер мәліметер бірегей топтан емес, жеке қатарладан тұрса, онда оны Қатар (Ряд) қыстырмасы бойынша енгізген дұрыс. Диаграмманы безендіру. Диаграма шеберінің үшінші сатысы ( Ары қарай батырмасын шерту арқылы алынады ) диаграмманы безендіруден тұрады. Диаграмма шебері терезесінің қыстырмларына төмендегі параметрлер енгізіледі: • диаграмманың аты, осьтерінің атаулары (Тақырыптары қыстырмасында); • коордиаттық осьтердің кескінделуі мен белгіленуі (Осьтер қыстырмасында); • координата осьтеріне параллель тор сызықтардың кескінделуі (Тор сызықтар қыстырмасында); • тұрғызылған осьтердің сипаттамасы (Атаунама қыстырмасында); • графиктің элементердің жеке мәліметтеріне сәйкес келетін атауларды бейнелеу ( Мәліметтер қолтаңбасы қыстырмасында ); • графикті тұрғызуда пайдалынылған мәліметтерді кесте түрінде көрсету ( Мәліметтер кестесі қыстырмасында); Диаграмманы орналастыру. Ары қарай (Далее) батырмасын басу арқылы Диаграмма шеберінің соңғы сатысына көшеміз. Бұл терезеде диаграмманы жаңа параққа немесе бұрынғы жұмыс парақтарынң біреуіне орналастыратынымыз жайлы сәйкес өрістердің біреуіне жауап бреміз. Дайын (готово) батырмасын шертіп, өзіміз көрсеткен парақта орналасқан дайын диаграмманы аламыз. Диаграмманы редакциялау. Дайын болған диаграмманы түзетуге болады. Ол келесідей элементердің жиынтығынан тұрады: тақырыбы, тақырыптық осьтер, тор сызықтары, тұрғызу аймағы, маркерлер, сандық мәліметер және т.б. Диаграмманың кез-келген элементін тышқанның көмегімен ерекшелеп алып, параметрлерін өзгертуге болады. Пішім (Формат) командасының көмегімен ашылған терезеде диаграман пішімдеуге болады. Диаграманы өшіру үшін Delete пернесін басамыз немесе диаграмма орналасқан парағын алып тастау керек (Түзету (Правка) > Тазарту (Очистка)). Кестені баспаға шығару. Excel-де қазға шығармас бұрмын алдын-ала оның ойдағыдай болуын тексеретін мүмкіндік бар. Ол үшін Файл > Қарау (Просмотр) командасын орындау керек. Стандарты аспаптар панелінен Қарау батырмасын басу қажет. Бұл команда кестені экранға шығарып береді, бірақ кестені бұл режимде түзете алмаймыз. Электрондық кестені мәліметтер базасы ретінде пайдалану. Мәліметтер базасы деп өзара байланысқан кестелер жиынтығын айтамыз. Ең қарапайым мәліметтер базасы бір ғана кестеден тұрады. Осындай мәліметтер базасы ретінде Excel электрондық кестесін алуға болады. Excel мәліметтер базасына тән барлық адамдарды орындайтын функциялар жиынтығын қамтиды. Мәліметтер базасындағы мәліметтер жазбалар жиынтығынан тұрады. Әрбір жазбаға бір өріс сәйкестендірілген. Жазбалар реттк нөмірімен, ал әрбір өріс оны сипаттайтын тақырыбымен анықталады. Excel-дің жұмыс парағын мәліметтер базасы ретінде қарастыру үшін, оған мынадай талаптар қойылады. Жұмыс парағының әрбір бағанына бір өріс сәйкестендіріледі. Мәліметтер базасының бағандары үзіліссіз, бірінен кейін орналасуы тиіс. Әрбір бағанның бірінші жолында қайталанбайтын өріс тақырыптары көрсетілуі керек. Өрістің тақырыбы бір ұяшықтан аспайтындай боуы керек. Мәліметтер базасының жазбалары тікелей тақырып жолдарының астына орналысуы қажет. Жазбаларды бос жол тастамай, бірінен соң бірін енгізеді. Егер бос жол кездессе бұл мәліметтер базасының соңы деп есептеледі. Осылайша құрылған кестеге мәліметтер базасына тән көптеген амалдарды қолдануға болады. Алдымен мәліметтер базасындағы кез-келген ұяшықты таңдап алып, қажетті амалды орындай беру қажет. Сонда мәліметтер базасының бүкіл жазбалар ауқымы таңдалынып алынады. Мәліметтерді сұрыптау. Мәліметтер базасын сұрыптау үшін Мәліметтер > Сұрыптау (Данные > Сортировка) командасын орындайды.йда болған Ауқымды сұрыптау (Сортировка диапазона) терезесі сұрыптау жүргізілетін өрістерді таңдап алу үшін қызмет етеді. Егер осы жолда өрістер атулары берілген болса, онда осы таудың біреуін таңдап алу керек. Егер өріс атауы ретінде бағандардың белгіленуі берілген болса, соған сәйкес өріс белгісін таңдап алу керек. Ауқымды сұрыптау сұхбат терезесі үш жолдан тұрады: • алғашқы сұрыптау режимі (Сортировка по); • екінші сұрыптау режимі (Затем по); • үшінші сұрыптау режимі (В последнюю очередь, по). Егер алғашқы сұрыптау режимі бойынша жүргізілген сұрыптау берілген кестемен дәл келсе, онда екінші сұрыптауды таңдап аласыз. Үшінші сұрыпталу осылайша жүргізіледі. Кез-келген өріс бойынша жүргізілген сұрыпталу өсу немесе кему реті бойынша орындалады. Қажетті сұрыптау ретін таңдап алып, ОК батырмасын басу керек. Мәліметтер базасын сүзгілеу. Мәліметтер базасы орасан зор жазбаларды қамти алатындықтан (Excel-де жазбалар саны 65536 болады), әр қашанда барлық жазбаларды экранға шығару мүмкін емес. Жалпы жазбалар жиынтығынан оның аздаған экранын бейнелеу сүзгілеу деп аталады. Excel-дегі ең қарапайым сүзгілеу әдісін автосүзгі жүзеге асырады. Автосүзгіні қолдану. Автосүзгі режиміне көшу үшін Мәліметтер > Сүзгі > Автосүзгі (Данные > Фильтр > Автофильтр) командасын орындау керек. Команда орындалғаннан кейін мәліметтер базасының әрбір өрісі үшін стандартты сүзгілер жиынтығы түзіледі, олардың тізімі өріс атуының жанындағы жібелікпен ашылады. Соны шерті арқылы мәліметтерді сүзгілеу шарттарын беруге болады. Жалпы жағдайда Барлығы (Все) нұсқасы қолданылады. Бұл нұсқа бойынша мәліметтер базасы сүзгіленбей сол қалпында қалады. Алғашқы 10 нұсқа қандайда бір шарт бойынша мәліметтер базасынан қандай да бір жазбалар санын ( немесе пайызын ) сүзгілеп алуға мүмкіндік береді. Сүзгіні қолданып болғаннан кейін іріктеп алған жиынтыққа енбей қалған жазбалар экранда белгіленбейді. Қалып-күй жолдары мәліметтер базасы жазбаларының жалпы саны мен сүзгіленіп алынған жазбалар саны бейнеленіп тұрады. Сүзгілеу жасалған өріс тақырыптары көгілдіртүспен бейнеленеді. Сүзгілеп алынған мәліметтер базасын баспаға беруге немесе ол бойынша диаграмма тұрғызуға болады. Сонғы жағдайда сүзгілеу шартының өзгеруі диаграмманың түрін өзгертеді. Кеңейтілген сүзгі. Егер диаграмма сүзгілеу шартының өзгеруінен тәуелсіз болсын деп талап қойылса, онда жазбаның көшірмесін дайындап алу керек. Мұнда көшірмені кеңейтілген сүзгінің көмегімен жүзеге асырады. Кеңейтілген сүзгі құрылымдары бірдей екі мәліметтер базасымен жүргізіледі.Әдетте сүзгілеу шартын белгілеп қою үшін жеке жұмыс парағын дайындайды. Мәліметер > Сүзгі > Кеңейтілген сүзгі ( Данные > Фильтр > Расширеннй фильтр ) командасының көмегімен сүзгілеуді тұрған жерде орындауға немесе сүзгіленіп алған жазбаларды сол жұмыс кітабының кез-келген парағына жеке қоюға болады.

Мәліметтерді анализдеу[өңдеу]

Сүзгілеу құралдарымен қорытынды есептеулерді біріктіре отырып анализдеуге болады. Осындай анализдеудің нәтижесін құрама кестелер мен құрама диаграмма түрінде көрсетіледі. Құрамма диаграмма құрған кезде автоматты түрде сол мәліметер негізінде құрама кесте де тұрғызылады.

Құрама кесте тұрғызу[өңдеу]

Құрама екстені тұрғызу Құрама кесте шеберінің ( Мастер сводных таблиц и диаграмм ) көмегімен іске асырылады. Ол үшін алдымен мәліметтер базасына қатысты ұяшықтарды ерекшелеп алу қажет. Сонан кейін Мәліметтер > Құрама кесте (Данные > Сводные таблицы) командасын орныдау қажет. Құрама кесте шебері (Мастер сводных таблиц и диаграмм) жұмысының алғашқы сатысында мәліметтер типі мен құрама мәліметтерді безендіру түрін анықтап алады. Ары қарай (Далее) батырмасын шерткеннен кейін, мәліметтер базасындағы ауқым дұрыс таңдалғанына көз жеткізу керек. Тағы Ары қарай батырмасын шерткен соң құрама кестенің орны анықталады. Құрама кестені көбіне жаңа бетке орналастырады (Жаңа бет (Новая страница) ауыстырып-қосқышын тағайындау арқылы).

Құрама кестенің құрылымы[өңдеу]

Құрама кесте шебері (Мастер сводных таблиц и диаграмм) жұмысының келесі сатысында құрама кестенің мазмұны мен құрылымын қалыптастырып алады. Бұл терезеде құрама кестенің маекті берілген. Ол төрт аймақтан тұрады: Бет(Страница), Жол(Строка), Баған(Столбец) және Мәліметтер(Данные). Құрама кестенің әрбір аймағына мәліметтер базасының қайсыбір өрісі сәйкестендіріледі. Құрама кестені толтырған кезде мәліметтер сәйкес өрістерден автоматты түрде алынып қойылады. Оны толтыру үшін осы бетте мәліметтер базасының өріс атауларымен аталған батырмалар қолданалады. Құрама кесте шеберін (Мастер сводных таблиц и диаграмм) іске қосып, шебер жұмысының бірінші сатысында Құрама диаграмма ауыстырып-қосқышын тағайындау керек. Содан соң Ары қарай (Далее) батырмасын басып, құрама диаграмма тұрғызылады. Диаграмманы пішімдеу мен баптау оның жанама меню арқылы іске асырылады. Диаграмманың түрін өзгерту үшін ол тұрған аймаққа тышқанның оң батырмасын басып, жанама менюден Диаграмма типі бөлімін таңдап алу қажет. Осылайша жанама менюден Пішім (Формат) бөлімін таңдап алып, диаграмма пішімін өзгертуге болады.

Бақылау құралдары[өңдеу]

Жұмыс парағын бақылау. Excel-дің жұмыс парақтары құжаттарды даярлау үшін қолданылатын болса, онда оны қате енгізілген мәліметтерден сақтау қажет. Мәтінді енгізгенде қателерді қарап шығып, түзетуге болады. Сандық мәліметтерді енгізгенде жіберілегн қателер жай көзге көрінбейді. Көбінесе Excel-дің жұмыс парақтарының өзі қате өрнектерді қамтитын формулалардан тұрады. Формулалардағы қателерді екі топқа бөледі: есептелмейтін формулалар және циклдік сілтемелер. Қате формулаларды есптегенде нәтижесін алу мүмкін болмаған жағдайда Excel программасы сол ұяшыққа қатенің кодын шығарып береді. Циклдік сілтемеде Excel программасы қате жайлы хабарды бірден экранға шығарып береді. Егер формула есептеу кезінде басқа ұяшықтағы мәндерді пайдаланса, онда осы формула сол мәндерге тәуелді болып табылады, ал формула тұрған ұяшық тәуелді деп аталады. Керісінше, мәндері қолданылған ұяшық формуланың мәніне әсер етіп, әсер етуші деп аталады. Цикілдік сілтеме ұяшықтың мәні сол ұяшыққа тәуелді болады. Оның ең қарапайым түрі – егер ұяшық өзі-өзіне адрестелген болса. Егер программа кестеден цикілдік сілтемені тауыпалса, онда ол бірден қатежайында хабар береді және циклдік сілтеменің аспаптар панелін ашып береді. Циклдік сілтеме табылған ұяшықтар көгілдір дөңгелекшемен белгіленеді және қалып-күй жолында Цикл сөзі пайда болады. Циклдік сілтеменің аспаптар панелінде циклдік сілтемесі бар ұяшықтардың тізімі көрсетіледі. Егер циклдік сілтеме бірнеше ұяшықтарды қамтыса, онда оны тәуелсіз ұяшықтар мен әсер етуші ұяшықтар батырмасы арқылы ашып, қатесі бар ұяшықтарды тауып алуға болады.

[1]

Дереккөздер[өңдеу]

  1. Қазақ тілі терминдерінің салалық ғылыми түсіндірме сөздігі:Информатика және компьютерлік техника/ Жалпы редакциясын басқарған – түсіндірме сөздіктер топтамасын шығару жөніндегі ғылыми-баспа бағдаламасының ғылыми жетекшісі, педагогика ғылымдарының докторы, профессор, Қазақстан Республикасы Мемлекеттік сыйлығының лауреаты А.Қ.Құсайынов. – Алматы: «Мектеп» баспасы» ЖАҚ, 2002. – 456 бет. ISBN 5-7667-8284-5


Сытрқы сілтеме[өңдеу]

[1]